Scaleo Ji 1645

Aus Debacher-Wiki
Wechseln zu:Navigation, Suche

Bei meinem bisherigen Rechner zeigen sich langsam Macken, ein neuer Rechner muss also her. Andererseits soll das Gerät auch kein alzu großes Loch in die Haushaltskasse reißen. Ich habe mir also die Sauerei des Monats März 2007 vom MediaMarkt geholt.

Das ist ein Gerät mit folgenden Merkmalen:

  • Mainboard MS 7293
  • Dual Core 2 Duo
  • 1 GByte Hauptspeicher
  • 320 GByte Sata-Platte
  • Speicherkarten-Leser
  • DVD-Laufwerk
  • Multinorm DVD-Brenner


SATA-Festplatte

Auf dem Gerät ist beim der Auslieferung Windows Vista Home Premium vorinstalliert. Egal, es soll ein schönes Linux drauf. Leider ist das mit SuSE 10.2 nicht ganz trivial, da der Sata-Chipsatz nicht erkannt wird. Die Installation von OpenSUSE bricht mit der Fehlermeldung ab:

No hard disks were found for the installation
Pleas check your hardware!

Naja, eigentlich hatte ich gehofft, das diese Probleme inzwischen vorbei wäre. Immerhin ist der Zugriff auf die Pata-Laufwerke problemlos möglich. Nach etwas Recherche im Netz habe ich mehrere Hinweise gefunden, dass dieses Problem bekannt ist und wohl auch mit dem Kerne 2.6.20 gelöst sein sollte. Die aktuelle Knoppix 5.2 benutzt kann noch nicht mit dem Chipsatz umgehen, wohl aber die aktuelle Live-CD von Gparted, die benutzt schon den Kernel 2.6.20.

Ich habe also diese Distribution benutzt, um die Festplatte neu zu partitionieren. Die ursprüngliche Aufteilung war:

sda1   NTFS  (Recovery)    12 GB
sda2   NTFS  (Windows C)  240 GB
sda3   -
sda4   NTFS  (Windows D)   60 GB

Ich habe die Partition 2 deutlich verkleinert und in sda3 eine erweiterte Partition angelegt:

sda1   NTFS  (Recovery)    12 GB
sda2   NTFS  (Windows C)   82 GB
sda3   erweitert
sda4   NTFS  (Windows D)   60 GB
sda5   Swap                 2 GB
sda6   Ext3   /            68 GB
sda7   Ext3   /home        39 GB
sda8   Ext3   /reserve     34 GB

Danach habe ich mir auf den Seiten von http://www.viaarena.com/ die aktuellen Treiber geladen: Drivers -> Linux -> OpenSuSE Linux 10.2 -> IDE, Raid & Sata -> Pata and/or Sata Driver Disk -> via se10[1].2 driverdisk and install os for sata controllers appnote ver0.8.tar.gz

In diesem Archiv befinden sich mehrere Dateien, benutzt habe ich nur fdd-suse10.2.img. Dieses Disketten-Image habe ich nach /tmp kopiert und dann als Loopback gemountet.

mount -o loop /tmp/fdd-suse10.2.img  /mnt

Da der Rechner kein Diskettenlaufwerk hat, aber zwei CD-Laufwerke, habe ich mir den gesamten Inhalt von /mnt auf eine CD gebrannt.

Diese CD habe ich dann in das untere Laufwerk gelegt und ins obere die Installations-DVD von OpenSUSE 10.2 und den Rechner von der DVD gebootet. Wenn man bei der Installation die Sprache und die Zeitzone ausgewählt hat kommt eine Lizenzabfrage, nach der dann auf die Festplatte zugegriffen würde. Vor der Beantwortung der Lizenz anfrage habe ich dann die Treiber geladen:

mount /dev/hdd  /mnt
cd /mnt/linux/suse/i386-10.2/modules

Danach habe ich dann ein Modul entladen, damit die Karten-Laufwerke nicht mehr berücksichtigt werden:

 rmmod  usb_storage

dann können die Module geladen werden:

 insmod via82cxxx.ko
 insmod ahci.ko
 insmod sata_via.ko

Das letzte Kommando sollte etwas dauern, danach dann aber die Platte erreichbar sein, was mit

fdisk -l

überprüft werden kann.

Danach kann man auf die grafische Oberfläche zurück und die normale Installation weiterlaufen lassen. Spannend wird es dann, wenn der Rechner neu bootet. Dazu kann er nicht in der Lage sein, weil die richtigen Module noch nicht installiert sind. Also lässt man ihn von der DVD ins Rettungssystem laufen und aktiviert dort wieder wie oben beschrieben die Treiber von der CD. Hier muss man etwas aufpassen, mir hat YaST die 64Bit-Version installiert, man muss auf alle Fälle von der Treiber-Cd die richtige Version auswählen.

Nachdem nur wieder Zugriff auf die Festplatte besteht müssen die Module dorthin kopiert werden. Dazu dienen folgende Schritte:

 mkdir /tmp/platte
 mount /dev/sda6  /tmp/platte
 mount -t proc proc /tmp/platte/proc
 mount -t sysfs  sys  /tmp/platte/sys
 cp /mnt/linux/suse/<version>/modules/*.ko  /tmp/platte/tmp
 chroot  /tmp/platte

Nun habe ich für jedes der Module herausgesucht, wo die ursprüngliche Version liegt, z.B. mittels:

 find /lib/modules -name ahci.ko

und dann die neuen Module an die jewilige Position kopiert:

 cp /tmp/via82cxxx.ko  <Ziel>
 cp /tmp/ahci.ko  <Ziel>
 cp /tmp/sata_via.ko  <Ziel>

Nun muss noch die initrd neu erzeugt werden, damit die Module auch beim Start verfügbar sind. Dazu habe ich nachgeschaut, ob alle Module in der Datei

/etc/sysconfig/kernel

aufgeführt sind. Bei mir fehlte ahci, welches ich dann vor sata_via ergänzt habe.

Dann noch

 mkinitrd

Hier kann man noch einmal kontrollieren, ob wirklich alle Module auftauchen. Wenn ja, dann kann ein Reboot folgen, jetzt sollte die Installation ganz normal weiter laufen.

Achtung: Ein Kernel-Update muss jetzt unbedingt unterbleiben, weil sonst die Module nicht mehr passen. Wer seinen Kernel aktualisieren will, der muss jeweils die Treiber-Quellen patchen und Kernel und Module neu compilieren.

Grafikkarte NVIDIA GeForce 7500 LE

Das Gerät ist mit einer wenig verbreiteten Grafikkarte ausgestattet. Im Web ist dazu eigentlich nur zu finden, dass sie für Gamer nicht geeignet wäre, naja, kein Problem. Von OpenSUSE 10.2 wird die Karte mit dem offenen Nvidia-Treiber angesprochen und funktioniert auch unproblematisch, bis auf die 3D-Beschleunigung.

Nun gibt es bei Nvidia propietäre Treiber für Linux. Dummerweise habe ich mir im ersten Anlauf an die speziellen Pakete für OpenSUSE geladen und installiert, damit funktionierte die Grafikkarte leider nicht. Zum Glück hatte ich mit die ursprüngliche xorg.conf gesichert.. Also die beiden Pakete wieder deinstalliert und von http://www.nvidia.com/object/unix.html die aktuellste Version für AMD64/EM64T geladen (Version 1.0-9755). Geladen wird dann die Datei http://us.download.nvidia.com/XFree86/Linux-x86_64/1.0-9755/NVIDIA-Linux-x86_64-1.0-9755-pkg2.run, die ich nach /tmp/kopiert habe.

Die Installation verlief dann ganz einfach in wenigen Schritten, als Benutzer root (die Kernel-Quellen und Compiler müssen natürlich vorhanden sein):

init 3
sh /tmp/NVIDIA-Linux-x86_64-1.0-9755-pkg2.run

Dem Installations-Programm muss man einige Fragen passend beantworten, danach ist die Installation erfolgreich abgeschlossen und die neue Konfiguration kann erstellt werden:

sax2 -r -m 0=nvidia

danach dann mit

init 5

wieder in den Grafikmodus wechseln, das sollte es dann gewesen sein.

DVB-T Fernsehen

(in Arbeit) Eine Fernsehkarte wollte ich in das Gerät nicht wieder einbauen. Ich habe mir daher die CinergyT von Terratec gekauft. Die Karte wird per USB angeschlossen und vom Linux sofort unterstützt, es sind keinerlei Verrenkungen mit Firmware oder zusätzlichen Treiber notwendig. Das einzige kleine Problem besteht darin die Programme zur Anzeige richtig zu installieren und mit der richtigen Konfigurationsdatei zu versorgen.

Viele der Programme arbeiten mit den xine-Bibliotheken. Die sind bei SUSE nur in einer abgespeckten Version dabei. Es bietet sich also an diese Pakete erst einmal von Packman zu aktualisieren. Dazu muss man nur Packman als zusätzlich Installationsquelle eintragen und kann dann dessen Pakete benutzen.

Danach sollte der Zugriff auf die Fernsehkarte mit Kaffeine sofort funktionieren. Man muss nur dort einen Sendersuchlauf starten, wozu man erst einmal eine passende Frequenztabelle braucht, die man aber bei Kaffeine bequem auswählen kann, in meinem Fall de-hamburg.

Funktionsfähige Programme:

  • Kaffeine
  • xawtv4 (die 4 ist wichtig)
  • Klear (tolle Funktionen)